
Introduction to SolidWorks - worksheet.    
 
 
1 Extrude. 
 
 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Material: ABS Plastic 
Mass:            (84g) 

 

Bracket. 
 
1 square=10mm 

1 

For this example we will build up the model in the stages 
shown on the right here.  
 
The first four stages will each involve the following 
operations: 

• selecting  surface or plane 
• creating a sketch on that surface/plane 
• creating an Extruded Bose/Base solid feature using 

that sketch. 
 
The last stage will be the same only: 

• creating an Extruded Cut feature, where solid 
material is cut (removed) from the model. This 
makes the hole. 
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Feature 1)  
Making the flat bottom slab of the bracket. This will be the base or starting feature.  

• Select the top plane for sketching and start a sketch.  
• Use the origin as the start point of sketching, and draw the sketch below.   

This sketch will define the cross section which will be extruded to create the base. 
 

 

Make use of 
horizontal/vertical 
relations. 

Origin 
 

• Create the Extruded Bose/Base feature using this sketch. 
 
Feature 2)  
Making the vertical web. 

• Select the appropriate back face of base slab for sketching. 
• Create the sketch shown here. Make good use of relations as you sketch. 
• Create the Extruded Bose/Base feature using this sketch. 
 

 

Make use of coincident relations 
with existing geometry. 
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Feature 3)  
Making the lug. 

• Select the front face of the vertical web for sketching. 
• Create the sketch shown here. Make good use of relations as you sketch.  

 
This sketch is a bit more complicated. To add sketch relations, such as to make two 
lines/arcs tangent, select both of them at the same time, using the Ctrl key and select the 
appropriate relation from the Properties window. 

 

 

Make use of tangent relations. 

 
• Create the Extruded Bose/Base feature using this sketch. 

 
Feature 4)  
Making the small web connecting the base to the lug. 

• Select the back face of the lug for sketching. 
• Create the sketch shown here. Make good use of relations as you sketch. 
• Create the Extruded Bose/Base feature using this sketch. 
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Feature 5)  
Making the round hole. 

• Select the front face of the lug for sketching. 
• Create the sketch shown here. Make use of coincident or concentric relations as you 

sketch. 
• Create the Extruded Cut feature using this sketch. Use the Through All option. 

 

 
 
Now model each of these blocks. For practise make sure that you use both extruded boss/base & 
cut features. Remember to use symmetry in sketches/features where possible. 
 

 

2 3 4

5 6 7

 
One square = 10mm 
 
What is the minimum number of features needed to model each of these, just using extruded 
features? 
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Now try this crankshaft. Make up your own dimensions. 
Again, only use extruded boss/base & cut features. Consider 
the most useful position for the crank shaft model origin. 
 
 

8  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
2 Revolve. 
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10

11



 

 

12 

 
 
3  Extra features. 
 
Round, chamfer, hole wizard, mirror, pattern, shell & rib. 
 
3.1 Rounds and Chamfers: from examples 2 – 7, experiment with the round and chamfer 

features. Try to add 2mm radius rounds to all internally angled edges, and 1mm chamfers 
to a selection of externally angled edges. 

 
3.2 Hole Wizard. 
 

We will model a motorcycle wheel hub: 
 
1) The first feature. 
Sketch:   
Right Plane  
Circle, centre coincident with origin, Smart Dimension diameter of 130mm.  
 
Extruded Bose/Base:  
Midplane (for symmetry) 120mm. 
 
2) Add a brake disc hole using the Hole Wizard. 
 
Insert > Features > Hole > Wizard 
 
Leave as default except for: 
 
ANSI metric 
Bottoming tapped hole 
M10 x 1.25 
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Click on Positions tab and click on one side circular face of hub. This places the hole on 
that face. Click green tick. 

                                     

13 

 
To accurately position that hole, expand feature in Design Manager, and edit the 3D sketch. 

 
Select the point and change the co-ordinates appropriately: 
 
X 60.00 
Y 50.00 
Z 0.00 

 
3.3 Pattern the hole. 

 
First display centre axis of hub. 
 
View > Temporary Axes 
 
Insert > Pattern/Mirror > Circular Pattern… 
 
Select the hub axis, then the hole as the Feature to pattern, and set 5 instances of the 
pattern. 
 

3.4 Mirror the holes. 
 
 Insert > Pattern/Mirror > Mirror… 
 
 Mirror Face/Plane – Select the Right Plane, expand the model tree in graphics area. 
 

Select the Circular Pattern feature to mirror. 
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3.5 Create a central hole for bearings and wheel axle. 
 
 Insert a Revolved Cut. 
 
 Sketch on the Front Plane, as shown below: 

                      
 
3.6 Shell the hub. 

 
Insert > Features > Shell 
 
Set the thickness to 4mm and accept the remaining default values. 
 
View the result using the different Display modes.  
 
View > Display  - Experiment with them, particularly the Section view mode. 
 
You may like to add some internal Rounds or Chamfers. 
 
To remove the inner ‘tube’ of the hub, from the Design Manager tree, right click the Shell 
feature, Edit Feature, and select the inner hole surface in Parameters - Faces to Remove 
box. 
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For some extra practise: 
 
Model the rim around the hub. 

 

 
 

Insert a Revolved Bose/Base feature, using above sketch and then Mirror it. 
 

Model a spoke by inserting an Extruded Bose/Base feature, sketched on the Right Plane, 
extruded Mid Plane to 30mm depth.  
 
When sketching for this feature, experiment with the Spline and Convert Entities sketch tools. 
 
Add some Rounds and then Pattern the spoke. 
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For even more practise: 
 
Model each component  below, 14, 15 & 16, assign the correct material, right click Material 
feature in design tree, and then obtain the component mass using SolidWorks: 
 
Tools > Mass Properties… 
 Material: Plain Carbon Steel 

Mass:                   (2890g)  
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note reference to sketch origin. 

Plan the modelling.  Examine the geometry and try 
to break componenet down into simple features.   
 
You may decide to start by creating this sketch on 
the Right plane to create the 26mm extruded 
curved slot as the base feature. 
 
Leave fillets and remaining holes until last. 

Use rib feature 

14 

 
 All fillets & radii 4mm unless otherwise 

stated. 
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Examine the component geometry.  
You may make the following 
observations: 

Extrude either 
Blind in 
Direction 1 
and Direction 
2 or use the 
Mid Plane 
option. 

Use lower limit values 

Material: Brass 
Mass:         (2001g) 

15 

• The basic component can be 
made up using a series of 
horizontal and vertical extrusions.   

• There is symmetry for the major 
features in both of the vertical 
planes. This should be utilised 
when modelling. 

• Details such as holes and fillets 
(rounds) exist, which can be 
added last. 

 
Plan the modelling. 
This is up to you. There are many ways to 
achieve the same end result of course. 
You could start by modelling the central 
lug as the base feature, sketching on 
the Right plane.
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Material: 1060 Aluminium Alloy 
Mass:                     (5901g) 

16 

Examine the component geometry.  
 

• In your imagination break the component down into a collection of simpler solid shapes. 
• Choose an appropriate base feature to create first and build the model up from that. 
• It is normally better to leave details such as chamfers, fillets and small holes until last. 
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4  Assembling parts. 
 
4.1  Preparation. 
 
You will need to download this zipped file and extract files: 
http://www.tech.plymouth.ac.uk/dmme/cad/cad_files/motion.zip 
 
Model and save this part in same folder as above downloaded files: 
 

 
 
4.2  Making the Assembly. 
 
Create a new ‘Assembly’ file.    View > Origins 
 
Insert the block, modelled above. Make sure that the origins are aligned by pressing Return to 
place the component, or… move pointer over assembly origin and click. 
 
Insert crank part. Use appropriate mates to position the crank in the block. 
 
Insert remaining parts appropriately, again using mates. 
 
4.3  Creating an ‘exploded’ view. 
 
Configurations allow us to capture different set ups of the same model/assembly file. 
Click on ConfigurationManager tab. 
Right click on the Default configuration feature and then click on New Exploded View… 
 
To set up the exploded view simply select a component and drag it to the exploded position and 
click the Done button. This completes this step. Now repeat for the other parts. When finished 
click the OK (green tick) button. To edit this exploded view, select it from tree and right click Edit 
Feature, etc. 
 
You can make as many different configurations/exploded views as you like. See the Help menu 
for more information. 
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5  Lofts (& sweeps). 
 
5.1  Simple loft. 
 
Create a cylinder: Insert an Extruded Boss/base, sketching on Front plane. Circle diameter 
100mm, extrude depth 30mm. 
 
Create new Reference Plane: 
Select Front plane, then Insert > Reference Geometry > Plane 
Set distance to 200mm. 
On this plane sketch a random closed spline shape like this: 
 
Use this sketch to create another 
Extruded Boss/base 30mm deep. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
 
Insert > Boss/Base > Loft 
 
Select two opposite faces. Observe Preview. Experiment with dragging blue points around, 
effecting twist of loft feature.  
 
5.2  Surface continuity examination. 
 
Complete feature. Examine surface shape, curvature: 
View > Display > Curvature 
 
Examine surface reflection appearance: 
View > Display > Zebra Stripes 
 
Note what happens at join of different surfaces. 
 
Select/right click/Edit feature on Loft. 
 
Experiment with the start/end constraints parameter settings. OK the feature and re-examine 
curvature and zebra stripes. 
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5.3  Freeform modelling. 
 
Practise using the loft feature to model a motorcycle fuel tank, following these steps: 
 
Tank is symmetrical, so model half. 
 
Create three separate sketches to use as the profiles for the loft. 
 
Sketch 1, on the Right plane: Add the appropriate Smart dimensions & Relations to the spline 
and horizontal line.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Sketch 2, on the Right plane: 
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Sketch 3, on the Top plane: 

  
 
Create the Loft feature, experiment with the Start/End Constraints settings, etc. 
 
Mirror the tank half.  
 
Add an Extruded Cut for the frame cut out.  
You may like to use the Tools > Sketch Tools > Intersection curve. If this leaves fragments, you 
may need to extend the sketch beyond the tank profile. 

 
 
Add a Revolved Boss/Base for the fuel 
filler. 
 
Add  any extra finishing Rounds, etc.  
 
Add a Shell feature to hollow out the tank. 
 
 
5.4  Sweeps. 
 
Sweeps are similar, but use one profile and a path.  See the Help > SolidWorks Tutorials for 
more. 
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6  2D drawings, photo-rendered images & data sharing. 
 
6.1  2D drawings of 3d model. 
 
Help > SolidWorks tutorials  - Lesson 3 – Drawings 
     Advanced Drawings 
 
6.2  Photo-rendered 2d image of 3d model. 
 
Help > SolidWorks tutorials  - PhotoWorks 
 
Tools > Add-ins -    PhotoWorks 
 
 
6.3  Data sharing. 
 
To save SolidWorks file in a different format, to open in other cad software. 
 
File > Save as… 
 
If specific format is not listed, try using a neutral format: 
 
6.3.1  Neutral formats. 
 
File formats that are not software specific: 
 
For most accurate 3d model, use one of these if possible: 
 
STEP    *stp Preferred, as it usually captures the models features. 
PARASOLID  *.x_t Good for cad software built on parasolid kernel, e.g. Pro/Engineer. 
IGES   *.igs Good for most 3d cad software. 
 
For faceted approximations to the 3d model geometry: 
 
STL   *.stl Usual format for rapid prototyping. 
VRML   *.wrl Web presentation.  
DXF   *.dxf Limited for 3d, but works. Useful for AutoCAD users and 2d work. 
 
 
6.3.2  E-drawings – SolidWorks free viewer program. 
 
Download from http://www.solidworks.com  
 
Save as a E-Drawing part/assembly/drawing send your models to people without SolidWorks
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Further work: 
 
Help > SolidWorks Tutorials 
 
Online tutorial title:    Completed: 
1) 30 minute lesson.    
2) Lesson 1 – Parts  
3) Lesson 2 – Assemblies  
4) Assembly mates  
5) Fillets  
6) Lofts  
7) Pattern Features  
8) Revolves & Sweeps  
Any of the remaining tutorials, as required….  
 
 
 
 
 
 
 
 
 
 
 
 
 

General tips on modelling: 
 
a) In your imagination break the component down into a collection of simpler solid 
shapes. 
 
b) Choose an appropriate base feature to create first and build the model up from that. 
 
c) In the more complex models it is normally better to leave details such as chamfers, 
fillets and small holes until last. 
 

 
 
 
REMEMBER: 
 

• Each sketch you create should end up being Fully Defined. This means that its location, 
with respect the model origin or other geometry, and sizes are all specified. Blue lines in 
sketches are Under Defined. 

 
• Every sketch for a feature must consist of lines that form continuous loops or perimeters. 

These loops or perimeters must not intersect themselves.  No lines should lie over other 
lines or be duplicated. Lines must join at their ends. 

 

 
  Good       Bad  Bad          Bad 
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